Contents

Previous Topic

2. TSUBAME での利用方法 (ANSYS Fluent 編)

Next Topic

改版履歴

3. TSUBAME での利用方法 (ANSYS Mechanical 編)

Note

ANSYS Fluent の使用方法は 2 TSUBAME での利用方法(ANSYS Fluent 編) をご参照ください.

3.1 モデル作成から,ジョブ実行,結果表示までのフロー

モデル作成から,ジョブ実行,結果表示までの一連のフローは次の通りとなっています.

(形状作成と修正)   ANSYS Design Modeler, SpaceClaim Direct Modeler(Windows版のみ)
(メッシュ作成)  ANSYS WB Mechanical(ANSYS Meshing)
(設定) ANSYS WB Mechanical
(ソルバー)   ANSYS WB Mechanical
(ポスト処理) ANSYS WB Mechanical

以下は,TSUBAME で ANSYS Mechanical を利用する際の個別手順となります.

(1) TSUBAMEにログイン

次のコマンドを入力し,TSUBAMEにログインします.

$ ssh -YC login-t2.g.gsic.titech.ac.jp -l USER-ID

Note

  • -l USER-ID の -l は数字の1ではなくアルファベットLの小文字です.
  • GUI 起動のため,cygwin などの X サーバソフトウェアを用いて TSUBAME に接続してください.
  • ssh コマンドによる TSUBAME へのログインの際,X11転送のため-Y オプションを指定してください.
  • -C は圧縮用のオプションで,GUI の操作の重さを軽減します.

(2).ANSYS Workbench の起動および入力ファイルの作成

Ansys Workbench は次のコマンドにより,起動できます. 特にバージョンの指定がない場合は,バージョン17.2が起動するようになっています.

$ runwb2

Note

異なるバージョンを使用する場合は,パス設定の変更が必要となります.

○バージョン18.1を使用する場合

<bash 系の場合>  $ source /usr/apps.sp3/isv/ansys_inc/set_ansys-18.1.sh
<csh 系の場合>   % source /usr/apps.sp3/isv/ansys_inc/set_ansys-18.1.csh

○バージョン18.0を使用する場合

<bash 系の場合>  $ source /usr/apps.sp3/isv/ansys_inc/set_ansys-18.0.sh
<csh 系の場合>   % source /usr/apps.sp3/isv/ansys_inc/set_ansys-18.0.csh

○バージョン17.1を使用する場合

<bash 系の場合>  $ source /usr/apps.sp3/isv/ansys_inc/set_ansys-17.1.sh
<csh 系の場合>   % source /usr/apps.sp3/isv/ansys_inc/set_ansys-17.1.csh

○バージョン16.2を使用する場合

<bash 系の場合>  $ source /usr/apps.sp3/isv/ansys_inc/set_ansys-16.2.sh
<csh 系の場合>   % source /usr/apps.sp3/isv/ansys_inc/set_ansys-16.2.csh

○バージョン12.1~16.1の場合

バージョン16.1
  <bash 系の場合>  $ source /usr/apps.sp3/isv/ansys_inc/set_ansys-16.1.sh
  <csh 系の場合>   % source /usr/apps.sp3/isv/ansys_inc/set_ansys-16.1.csh
バージョン16.0
  <bash 系の場合>  $ export PATH="/usr/apps.sp3/isv/ansys_inc/v160/ansys/bin/:${PATH}"
  <csh 系の場合>   % setenv PATH "/usr/apps.sp3/isv/ansys_inc/v160/ansys/bin/:${PATH}"
バージョン15.0
  <bash 系の場合>  $ export PATH="/usr/apps.sp3/isv/ansys_inc/v150/ansys/bin/:${PATH}"
  <csh 系の場合>   % setenv PATH "/usr/apps.sp3/isv/ansys_inc/v150/ansys/bin/:${PATH}"
ANSYS MECHANICAL

ここでは,Static Structual で説明していきます. Ansys Workbench を起動後,左部にある「Static Structual」の部分をダブルクリックすることで,次の図のように Project Schematicウインドウに Static Structual ができます.Geometory をクリックすると,ANSYS Design Modeler が起動します.

ANSYS MECHANICAL

形状作成と修正,メッシュ作成や計算の設定が完了したら,計算を行うための入力ファイルを ANSYS WB Mechanical 上のツールバーから「Tools」→「Write Input files...」で出力します.

(3).計算の実行

計算は ANSYS WB Mechanical 上からも可能です.学内配布している Windows 版で行う場合は,Solutionを右クリックし、Solveを選ぶと解析が実行されます。

ANSYS MECHANICAL

TSUBAME 上でも同様の手順でジョブ実行できますが,インタラクティブノード上では 30 分の時間制限があり,長時間のジョブ実行はできません.そのため,ANSYS WB Mechanical 上で入力ファイルを出力し,PBS でのバッチ投入により計算を行います.

まず,ソルバーのコマンドラインでの実行方法を説明し,その次に PBS でのバッチ投入手順を説明します.

ソルバーは ansys172 コマンドで実行します.使用するコンピュートリソースによって,次のようにオプションを使い分けてください.

1 core の場合
$ ansys172 -b -i <入力ファイル> -o file.out

・ 4 core (Shared memory) の場合
$ ansys172 -b -np 4 -i <入力ファイル> -o file.out

・GPU 2 枚の場合
$ ansys172 -b -dis -acc nvidia -na 2 -i <入力ファイル> -o file.out

Note

異なるバージョンを使用する場合は,コマンドの差し替えが必要となります.

○バージョン18.1の場合: ansys181 コマンド

○バージョン18.0の場合: ansys180 コマンド

○バージョン17.1の場合: ansys171 コマンド

○バージョン16.2の場合: ansys162 コマンド

○バージョン16.1の場合: ansys161 コマンド

○バージョン16.0の場合: ansys160 コマンド

○バージョン15.0の場合: ansys150 コマンド

次に PBS でのバッチ投入手順です.

・シングルジョブ(1 core)の場合

(a).投入シェルスクリプト準備(スクリプト名: test_mechanical.sh)

#!/bin/sh
cd ${PBS_O_WORKDIR}

ansys172 -b -i <入力ファイル> -o file.out

(b).実行権限付与

$ chmod +x test_mechanical.sh

(c).ジョブ投入

$ t2sub <グループ,キュー等指定> test_mechanical.sh

・MPIジョブ(Shared memory)の場合

(a).投入シェルスクリプト準備(スクリプト名: test_mechanical.sh)

#!/bin/sh
cd ${PBS_O_WORKDIR}

ansys172 -b -np <core数> -i <入力ファイル> -o file.out

(b).実行権限付与

$ chmod +x test_mechanical.sh

(c).ジョブ投入

$ t2sub -l select=1:ncpus=<core数> <グループ、キュー等指定> test_mechanical.sh

・GPUジョブの場合

(a).投入シェルスクリプト準備(スクリプト名: test_mechanical.sh)

#!/bin/sh
cd ${PBS_O_WORKDIR}

ansys172 -b -dis -acc nvidia -na 2 -i <入力ファイル> -o file.out

(b).実行権限付与

$ chmod +x test_mechanical.sh

(c).ジョブ投入

$ t2sub -l select=1:ncpus=<core数>:gpus=<GPU数> <グループ、キュー等指定> test_mechanical.sh

(4).結果の表示

WB Mechanical で「Tools」→「Read Result files...」でデータを読み込みます.

読み込むファイルの拡張子は,解析の種類によって異なり,主なものは以下の通りです.

.rst: 構造解析,あるいは連成解析の結果ファイル
.rth: 伝熱解析の結果ファイル
.rmg: 磁場解析の結果ファイル

file.err, file.out も削除せずに残しておくと,WB Mechanical に読み込んでから解析の状況も表示されます.

ANSYS MECHANICAL

3.2 スクリプトファイルによるコマンドラインでのジョブ実行

Workbench では,スクリプトファイルを用いて,コマンドラインでのジョブ実行が可能です.

Note

活用例: 複数の解析設定を含む Workbench ファイルやパラメータ解析などに便利です.

スクリプトファイルによるコマンドラインでのジョブ実行の流れ

次の図のように GUI 上の操作で Model まで完了していて(図の左側), 以降の処理をスクリプトファイルでコマンドライン実行する例で説明します. コマンドライン処理実行完了後は図の右側の状態になります.

ANSYS MECHANICAL

まず,スクリプトファイルを次の内容で作成します.

# encoding: utf-8
SetScriptVersion(Version="15.0")
Open(FilePath="/work1/t2g-testgroup/batch_r15.wbpj")  ← パス,ファイル名は,ご自身のものに差し替えてください.
Update()
Save(Overwrite=True)

先ほど作成したスクリプトファイルを指定して,コマンドライン実行します.

$ runwb2 -b -r ./<スクリプトファイル名>

自分でスクリプトファイルを作成する方法

通常の解析であれば,上記スクリプトファイルの内容で十分ですが, パラメータ解析する場合など,新たにスクリプトファイルを作成する手順を説明します.

まず,何もファイルを読み込んでいない状態で,[File]-[Scripting]-[Record Journal...] を選択します.

ANSYS MECHANICAL

これから作成するスクリプトファイルの名前(任意の名前で構いません)を入力します.

ANSYS MECHANICAL

[File]-[Open] を選択し,ワークベンチのプロジェクトファイルを開きます. [Update Project] ボタンをクリックすると解析が始まります.

ANSYS MECHANICAL

解析が終了したら,[File]-[Save] を選択します. [File]-[Scripting]-[Stop Recording Journal...] を選択肢し, スクリプトファイルの作成を終了します。

ANSYS MECHANICAL

3.3 ライセンス使用状況の確認

2.4 ライセンス使用状況の確認 をご参照ください. 1 ユーザあたりに利用可能な「ANSYS Academic Research HPC ライセンス」の token 数上限があることにご注意ください。