Contents

Previous Topic

6. プログラミングと環境

Next Topic

8. free アプリケーション

7. ISVアプリケーション(一部利用ユーザ制限あり)

【重要】

ライセンス契約上、ISVアプリケーションを利用できる利用者は限られます。 東工大に所属する 「1.学生証・職員証」 以外の利用者は以下に挙げる5つのアプリケーション以外のISVアプリケーションを利用することができません。

  • Gaussian/Gauss View
  • Intel Compiler
  • PGI Compiler
  • Total View Debugger
  • HMPP(のちのCAPS Compiler)

本章では,「TSUBAME2.5」で利用できるアプリケーションの基本操作について説明します.詳細な取扱いにつきましては,個別の利用手引を参照してください.

  • FLUENT
  • ABAQUS Standard/Explicit
  • ABAQUS CAE
  • NASTRAN
  • PATRAN
  • Gaussian
  • AMBER
  • Materials Studio
  • Discovery Studio
  • SCIGRESS
  • Molpro
  • mathematica
  • maple
  • AVS/Express
  • AVS/Express PCE
  • EnSight
  • MATLAB
  • LS-DYNA

7.1 ANSYS FLUENT

バージョン17.2 を使用できます.

1.[インタラクティブ実行]

$ fluent 3ddp <fluent オプション>
7.1-ANSYS_FLUENT isv

2.[PBSジョブ投入]

PBSの仕様上,GUIを使用できないため,コマンドラインモード(fluent の -g オプション)で起動します. また,予め次のようなジャーナルファイルをjournalという名で用意しておき処理を自動化することをお勧めします.

/file/read-case "sample.cas"
/solve/iterate 10
exit

(1).シングルジョブ

(a).投入シェル準備

$ cat test_fluent.sh

#!/bin/sh
cd ${PBS_O_WORKDIR}

fluent 3ddp -g -i journal <fluent オプション>
------------------------------------
$ chmod +x test_fluent.sh

(b).ジョブ投入

$ t2sub <グループ,キュー等指定> test_fluent.sh

(2).MPIジョブ投入

MPIジョブはノード内並列のみ対応しています.

(a).投入シェル準備

$ cat test_fluent.sh

#!/bin/sh
cd ${PBS_O_WORKDIR}

fluent 3ddp -mpi=openmpi -t<CPU数> -g -i journal <fluent オプション>
※V12.1(U, Vキュー), 15.0 の場合は -mpi=intel に差し替えてください.
------------------------------------
$ chmod +x test_fluent.sh

(b).ジョブ投入

ノード内並列で実行します.

$ t2sub -l select=1:ncpus=<CPUS数> <グループ,キュー等指定> test_fluent.sh

7.2 Abaqus Standard/Explicit

バージョン6.14-2を使用できます.

1.[インタラクティブ実行]

$ abaqus job=<入力ファイル> <Abaqus オプション>

2.[PBSジョブ投入]

(1).シングルジョブ

(a).投入シェル準備

$ cat test_abaqus.sh

#!/bin/sh
cd ${PBS_O_WORKDIR}

abaqus job=<入力ファイル> <Abaqus オプション>
------------------------------------
$ chmod +x test_abaqus.sh

(b).ジョブ投入

$ t2sub <グループ,キュー等指定> test_abaqus.sh

(2).MPIジョブ投入

MPIジョブはノード内並列のみ対応しています.

(a).投入シェル準備

$ cat test_abaqus.sh

#!/bin/sh
cd ${PBS_O_WORKDIR}

abaqus job=<入力ファイル> cpus=<CPU数> mp_mode=mpi <Abaqus オプション>
------------------------------------
$ chmod +x test_abaqus.sh

(注意) U, V キューを投入先とする場合は,スクリプト中の「mp_mode=mpi」の指定方法を変更する必要があります. 次のようなスクリプトを用意してください.

#!/bin/sh
cd ${PBS_O_WORKDIR}

abaqus job=<入力ファイル> cpus=<CPU数> mp_mode=threads <Abaqus オプション>

(b).ジョブ投入

ノード内並列のみです.

$ t2sub -l select=1:ncpus=<CPUS数> <グループ,キュー等指定> test_abaqus.sh

7.3 Abaqus CAE

バージョン6.14を使用できます.

1.[起動方法]

次のコマンドで起動します.

$ abaqus cae

終了は,メニューバーから「File」を選択し「Exit」をクリックします.

7.3-Abaqus_CAE isv

7.4 Patran

バージョン2016を使用できます.

1.[起動方法]

次のコマンドで起動します.

$ patran

終了は,メニューバーから「File」を選択し「Quit」をクリックします.

7.4-patran isv

7.5 Nastran

バージョン2016.1を使用できます.

1.[インタラクティブ実行]

$ nast20161 <入力ファイル> <Nastran オプション>

2.[PBSジョブ投入]

(1).シングルジョブ

(a).投入シェル準備

$ cat test_nastran.sh

#!/bin/sh
cd ${PBS_O_WORKDIR}

nast20161 <入力ファイル> <Nastran オプション>
------------------------------------
$ chmod +x test_nastran.sh

(b).ジョブ投入

$ t2sub <グループ,キュー等指定> test_nastran.sh

(2).MPIジョブ投入

MPIジョブはノード内並列のみ対応しています.

(a).投入シェル準備

$ cat test_nastran.sh

#!/bin/sh
cd ${PBS_O_WORKDIR}

nast20161 <入力ファイル> parallel=<CPU数> <Nastran オプション>
------------------------------------
$ chmod +x test_nastran.sh

(b).ジョブ投入

ノード内並列のみです.

$ t2sub -l select=1:ncpus=<CPUS数> <グループ,キュー等指定> test_nastran.sh

7.6 Gaussian 16

Revision A.03を使用できます.

1.[インタラクティブ実行]

$ g16 test000.com

2.[PBSジョブ投入]

大きなサイズのスクラッチが出力される場合があります. シェルスクリプトで「export GAUSS_SCRDIR=$TMPDIR」の指定を行い, 共有スクラッチ領域を使用することをおすすめします.

(1).シングルジョブ

(a).投入シェル準備

$ cat test_g16.sh

#!/bin/sh
cd ${PBS_O_WORKDIR}

export GAUSS_SCRDIR=$TMPDIR

g16 test000.com
------------------------------------
$ chmod +x test_g16.sh

(b).ジョブ投入

$ t2sub <グループ,キュー等指定> test_g16.sh

(2).SMP並列ジョブ

・CPU 12 コアを指定する例

(a).投入シェル準備

$ cat test_g16smp.sh

#!/bin/sh
cd ${PBS_O_WORKDIR}

export GAUSS_SCRDIR=$TMPDIR

g16 -c=0-11 test0000.com
------------------------------------
$ chmod +x test_g16smp.sh

(b).ジョブ投入

$ t2sub -l select=1:ncpus=12 <グループ,キュー等指定> test_g16smp.sh

(3).Lindaジョブ投入

・4ノード、ノードごとにCPU 12 コアを指定する例

(a).投入シェル準備

$ cat test_g16linda.sh

#!/bin/sh
cd ${PBS_O_WORKDIR}

export GAUSS_SCRDIR=$TMPDIR

g16 -w="`cat $PBS_NODEFILE | tr "\n" "," | sed s/,$//`" -c=0-11 test0000.com
------------------------------------
$ chmod +x test_g16linda.sh

(b).ジョブ投入

$ t2sub -l select=4:ncpus=12 -l place=scatter <グループ,キュー等指定> test_g16linda.sh

7.7 Gauss View

バージョン6.0.16を使用できます.

1.[起動方法]

次のコマンドで起動します.

$ gview

終了は,メニューバーから「File」を選択し「Exit」をクリックします.

7.7-GaussView isv

7.8 AMBER

バージョン16(update1)を使用できます.

1.[インタラクティブ実行]

$ sander [-O|A] -i mdin -o mdout -p prmtop -c inpcrd -r restrt <sander オプション>

2.[PBSジョブ投入]

Note

U/Vキューを投入先とする場合の注意点

U/V キューを投入先とする場合は,次のように U/V キュー専用の AMBER を使用するための環境変数設定をジョブスクリプトに記述してください. U/V キュー以外を投入先とする場合は,この設定は必要ありません.

この環境変数設定が無い場合,一部コマンドはエラーとなり正常に計算できません.

    <bash 系の場合>  $ source /usr/apps.sp3/isv/amber/16_update01/i2013.1.046_mpch3.1_VM/amber16/amber.sh
    <csh 系の場合>   % source /usr/apps.sp3/isv/amber/16_update01/i2013.1.046_mpch3.1_VM/amber16/amber.csh

○MPI 実行する場合
  <bash 系の場合>  $ source /usr/apps.sp3/env/set_mpch-3.1_i2013.1.046.sh
  <csh 系の場合>   % source /usr/apps.sp3/env/set_mpch-3.1_i2013.1.046.csh

(1).シングルジョブ

(a).投入シェル準備

$ cat test_sander.sh

#!/bin/sh
cd ${PBS_O_WORKDIR}

sander [-O|A] -i mdin -o mdout -p prmtop -c inpcrd -r restrt <sander オプション>
------------------------------------
$ chmod +x test_sander.sh

(b).ジョブ投入

$ t2sub <グループ,キュー等指定> test_sander.sh

(2).GPU(pmemd.cuda)ジョブ投入

(a). 投入シェル準備

$ cat test_pmemd.cuda.sh

#!/bin/sh
cd ${PBS_O_WORKDIR}

pmemd.cuda [-O] -i mdin -o mdout -p prmtop -c inpcrd -r restrt <pmemd.cuda オプション>
------------------------------------
$ chmod +x test_pmemd.cuda.sh

(b). ジョブ投入

$ t2sub <グループ,キュー等指定> test_pmemd.cuda.sh

詳細は「AMBER 利用の手引き 7. GPU による高速化」を参照してください.

(3).MPIジョブ投入

(a).投入シェル準備

$ cat test_sander.sh

#!/bin/sh
cd ${PBS_O_WORKDIR}

mpirun -np <CPU数> -hostfile $PBS_NODEFILE \
  sander.MPI [-O|A] -i mdin -o mdout -p prmtop -c inpcrd -r restrt <sander オプション>
------------------------------------
$ chmod +x test_sander.sh

(b).ジョブ投入

  • ノード内並列

    $ t2sub -l select=1:ncpus=<CPU数>:mpiprocs=<CPU数> <グループ,キュー等指定> test_sander.sh
    
  • ノード間並列

    $ t2sub -l select=<ノード数>:ncpus=<各ノードのCPU数>:mpiprocs=<各ノードのCPU数> -l place=scatter \
    <グループ,キュー等指定>  test_sander.sh
    

7.9 Materials Studio

バージョン8.0 SP1を使用できます.

Windows にて,「スタートメニュー」→「すべてのプログラム」からMaterials Studioを起動します.

7.10 Discovery Studio

バージョン4.5を使用できます.

Windows にて,「スタートメニュー」→「すべてのプログラム」からDiscovery Studioを起動します.

7.11 SCIGRESS

Note

  • Scigress は2014年度末(2015/3/31)にてサービスを終了いたしました.

7.12 Molpro

Note

  • Molpro は2014年度末(2015/3/31)にてサービスを終了いたしました.

7.13 Mathematica

バージョン10.3を使用できます.

1.[起動方法]

次のコマンドで起動します.

<グラフィックユーザインタフェース>

$ Mathematica

画面左部の「Notebook >>」をクリックすることで,ノートブックが起動します. 終了は,メニューバーから「File」を選択し「Quit」をクリックします.

<コマンドラインインタフェース>

$ math
Mathematica 10.3 for Linux x86 (64-bit)
Copyright 1988-2014 Wolfram Research, Inc.

In[1]:= (終了する場合はQuitを入力します)
7.13-Mathematica isv

7.14 Maple

バージョン18.01を使用できます.

1.[起動方法]

次のコマンドで起動します.

<グラフィックユーザインタフェース>

$ xmaple

終了は,メニューバーから「File」を選択し「Exit」をクリックします.

<コマンドラインインタフェース>

> maple
    |\^/|     Maple 18 (X86 64 LINUX)
._|\|   |/|_. Copyright (c) Maplesoft, a division of Waterloo Maple Inc. 2014
 \  MAPLE  /  All rights reserved. Maple is a trademark of
 <____ ____>  Waterloo Maple Inc.
      |       Type ? for help.
> (終了する場合はquitを入力します)
7.14-Maple isv

7.15 AVS/Express

バージョン8.3を使用できます.

1.[起動方法]

次のコマンドで起動します.

$ xp

終了は,メニューバーから「File」を選択し「Exit」をクリックします.

7.15-AVS_Express isv

7.16 AVS/Express PCE

バージョン8.2を使用できます.

1.次のコマンドにより,起動します.

$ para_start <コア数>
7.16-AVS_Express_PCE isv

7.17 EnSight

Note

  • EnSight は2014年度末(2015/3/31)にてサービスを終了いたしました.

7.18 MATLAB

バージョンR2016bを使用できます.

1.[起動方法]

次のコマンドで起動します.

<グラフィックユーザインタフェース>

$ matlab

終了する場合は,[File]-[Exit]を選択してください.

<コマンドラインインタフェース>

$ matlab -nodisplay


                            < M A T L A B (R) >
                  Copyright 1984-2016 The MathWorks, Inc.
                  R2016b (9.1.0.441655) 64-bit (glnxa64)
                             September 7, 2016


To get started, type one of these: helpwin, helpdesk, or demo.
For product information, visit www.mathworks.com.

>> (終了する場合はexitを入力します)
7.18-MATLAB isv

7.19 LS-DYNA

バージョンR8.0.0を使用できます.

1.[インタラクティブ実行]

$ smpdynas i=<入力ファイル>

2.[PBSジョブ投入]

(1).シングルジョブ

(a).投入シェル準備

$ cat test_smpdynas.sh

#!/bin/bash
cd ${PBS_O_WORKDIR}

smpdynas i=<入力ファイル>
------------------------------------
$ chmod +x test_smpdynas.sh

(b).ジョブ投入

$ t2sub <グループ,キュー等指定> test_smpdynas.sh

(2).MPIジョブ投入

MPIジョブはノード内並列のみ対応しています.

(a).投入シェル準備

$ cat test_mppdynas.sh

#!/bin/bash
cd ${PBS_O_WORKDIR}

source /usr/apps.sp3/isv/lsdyna/set_lsdyna-R8.0.0.sh
mpirun -np <CPU数> mppdynas i=<入力ファイル>
------------------------------------
$ chmod +x test_mppdynas.sh

(b).ジョブ投入

ノード内並列のみです.

$ t2sub -l select=1:ncpus=<CPUS数> <グループ,キュー等指定> test_mppdynas.sh