2015春メンテで何が変更されたのでしょう。 (2015/4/2 新規)

2015年春のメンテナンスでの変更点の詳細な情報を以下にまとめました.

1. 変更点概要

変更点の概要は以下の通りです.詳細は,以降の章で説明します.

○L系キュー(L128, L128F, L256, L512) の計算ノード

  • OSのアップグレード
     
  • 各種アプリケーション(MPIライブラリ,CUDA,ISV・Freeアプリケーション)のパス変更.
    一部アプリケーションのバージョンアップ

○全ての計算ノード

  • 各ミドルウェアのアップデート
  • 一部アプリケーションのバージョンアップ
  • 一部アプリケーションのサービス終了

 

2. OSアップグレード

L系キュー(L128, L128F, L256, L512)メンテナンス前後の OS の変更は次表の通りです.
(全てのマシンが同じ環境になりました)

  メンテナンス前(L系) メンテナンス後(L系を含む全てのマシン)
OS SUSE Linux Enterprise Server 11 SP1 SUSE Linux Enterprise Server 11 SP3
カーネル 2.6.32.12-0.7 3.0.76-0.11

3. アプリケーション(MPI,CUDA,ISV・Free)

ユーザ様にて,特に影響を受け,対応が必要となることは以下の通りです.

  • 自前で用意したプログラムがそのままでは動作しなくなる場合があります.そのため,実行モジュールの再コンパイルをお願いいたします.もし,再コンパイルが上手くいかない場合はお問い合わせフォームまでご連絡ください.
     
  • .bashrc などで環境変数を設定されている方は,アプリケーションのパス変更にご注意ください.
     
  • 一部,ISV・Free アプリケーションは,新OSに従来提供していたバージョンが対応しておらず,より新しいバージョンを導入しております.アプリのバージョン違い,モジュールを作成する際のコンパイラの違いにより,計算結果が同一とならない点にご注意ください.

インストールディレクトリ,パスの変更は次表の通りです.太字になっているものが,TSUBAMEのシステム設定でパスが通されているものです.

項目 メンテナンス前(L系) メンテナンス後(L系を含む全てのマシン)
CUDA
  • 4.0 (/opt/cuda/4.0/)
  • 4.1 (/opt/cuda/4.1/)
  • 5.0 (/opt/cuda/5.0/)
  • 5.5 (/opt/cuda/5.5/)
  • 5.0 (/usr/apps.sp3/cuda/5.0/)
  • 5.5 (/usr/apps.sp3/cuda/5.5/)
  • 6.0 (/usr/apps.sp3/cuda/6.0/)
  • 6.5 (/usr/apps.sp3/cuda/6.5/)

※ Ver 5.0, 5.5 は OS サポート対象外です.

OpenMPI
  • 1.4.2 (Intel Compiler 11.1.072) (/usr/apps/openmpi/1.4.2/intel/)
  • 1.6.5 (Intel Compiler 2013.1.046) (/usr/apps.sp3/mpi/openmpi/1.6.5/i2013.1.046/)
Mvapich2
  • 1.5.1 (Intel Compiler 11.1.072) (/usr/apps/mvapich2/1.5.1/intel/)
  • 2.0rc1 (Intel Compiler 2013.1.046) (/usr/apps.sp3/mpi/mvapich2/2.0rc1/i2013.1.046_cuda6.5/)
mpich2
  • 1.3 (Intel Compiler 11.1.072) (/usr/apps/mpich2/1.3/intel/)
  • 3.1 (Intel Compiler 2013.1.046) (/usr/apps.sp3/mpi/mpich2/3.1/i2013.1.046/)
nkf
  • /usr/bin/nkf
  • /usr/apps.sp3/free/bin/nkf

4. ミドルウェアのアップデート

項目 メンテナンス前(L系) メンテナンス後(L系を含む全てのマシン)
    インタラクティブ
キュー(S, S96, L128, L128F, L256, L512, G, H, X)
キュー(U, V)
Infiniband Driver, OFED 1.5.3.3.0.0 2.2-1.0.1
Lustre Client 1.8.7 2.5.27
GPFS Client 3.3.0.2 3.4.0-29
PBS 12.0.1, 12.2.1混在 12.2.1

 

5.アプリケーションのデフォルトバージョン

  以下のように更新されます。古いバージョンを利用する場合にはパスの指定をしてください。

  • ABAQUS/ABAQUS CAE 6.13-3 -> 6.14-2
  • ANSYS 15.0 -> 16.0 (4/2更新)
  • Sigress サービス終了
  • Molpro サービス終了
  • Mathematica 9.0.1 -> 10.0.110.0.2 (4/2更新)
  • MATLAB R2014b -> R2015a
  • Maple 17.02 -> 18.01
  • AVS/Express 8.1 -> 8.2
  • AVS/Express PCE 8.1 -> 8.2
  • EnSight サービス終了
  • Intel VTune Amplifier 2011 -> 2015
  • PGI C/Fortran Compiler 14.6 -> 15.1
  • TotalView Debugger 8.9.2-0 -> 8.14.1-8